Systemmeldung: MXM – UniRecWriterThread – hole detected — was ist defekt?

CamTelligence >> Mobotix Forum >> Mobotix Fehlersuche (Fehlermeldungen, LED Status etc.) >> Systemmeldung: MXM – UniRecWriterThread – hole detected — was ist defekt?

Dieses Thema enthält 3 Antworten und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  Torben Vanselow vor 4 Wochen, 1 Tag.

Ansicht von 4 Beiträgen - 1 bis 4 (von insgesamt 4)
  • Autor
    Beiträge
  • #21787

    MobotixFan
    Teilnehmer

    Hallo Torben,

    eine meiner S15D (betrieben mit einem 6MP-Tag-Sensormodul) liefert sporadisch alle paar Tage mal u.a. die Systemmeldung „hole detected“, zuletzt dreimal an einem Tag:


    09:51:08 MXM EventDAgent mxm eventd agent

    09:51:08 EVENT process Bilderzeugung wird gestartet…

    09:51:08 EVENT REC Read information of last event from record/events/028/632/E00000.jpg in 0.006 sec

    09:51:08 EVENT process Bildgenerierung ist online

    09:51:10 EVENT arming Aktionen aktiviert

    09:53:30 STORAGE check[1372] Transfer of image files delayed more than 120 seconds!

    10:07:43 MXM UniRecWriterThread hole detected, seq_no=3919, expected=3918

    10:09:30 STORAGE check[1372] Transfer of image files OK.

    15:08:11 MXM EventDAgent mxm eventd agent

    15:08:11 EVENT process Bilderzeugung wird gestartet…

    15:08:11 EVENT REC Read information of last event from record/events/028/660/E00000.jpg in 0.007 sec

    15:08:11 EVENT process Bildgenerierung ist online

    15:08:13 EVENT arming Aktionen aktiviert

    15:12:01 STORAGE check[1372] Transfer of image files delayed more than 120 seconds!

    15:14:08 MXM UniRecWriterThread hole detected, seq_no=4071, expected=4070

    15:15:31 STORAGE check[1372] Transfer of image files OK.

    18:42:57 MXM EventDAgent mxm eventd agent


    Das Vorkommnis startet immer mit einem

    MXM EventDAgent mxm eventd agent

    mit sofort anschließendem

    EVENT process Bilderzeugung wird gestartet…

    Betrachtet man die aufgezeichneten Frames, so ist zuerst mindestens ein Frame komplett schwarz, dann folgen Frames mit starken Farbabweichungen. Wenige Frames später sind die Bilder dann wieder wie gewohnt in guter Qualität. Die eingeblendeten Texte (bspw. Datum&Uhrzeit) werden auf allen Frames von Beginn an (auch beim ersten schwarzen Frame) angezeigt.

    Frage: Welche Komponente ist defekt und sollte getauscht werden? Das Sensormodul, das Sensorkabel oder der S15D-Body.

    Meine Vermutung wäre Sensormodul und/oder Kabel, da die Texteinblendung die ganze Zeit über vorhanden ist. Die Klapp-Ferrit-Elemente sind an beiden Enden des Kabels angebracht, max. 10cm entfernt vom jeweiligen Ende. Die SD-Karte sollte es auch nicht sein, die liefert im Fehlerfall typischerweise andere Meldungen. Die noch relativ neue SD-Karte habe ich erst vor Kurzem zweimal MxFFS-formatiert (sichere/tiefe Formatierung), um Fehler von dieser Seite her auszuschließen.

    [Firmware-4.7.2.18]

    Grüße, ein MobotixFan

    Dateianhänge:
    You must be logged in to view attached files.
    #21803

    Torben Vanselow
    Keymaster

    Hallo MobotixFan,

    zwei Indizien weisen eindeutig auf Übertragungsprobleme Richtung NAS hin.

    • die Verzögerung der Speicherung einer Bildsequenz um über 120 Sekunden
    • das „hole“ Loch, daher die fehlende Bildsequenz auf dem Speichermedium

    Irritiert hatte mich der Schwarze Frame – darum hielt ich kurz Rücksprache mit dem Mobotix-Support. Aber auch hier teilt man meine Einschätzung.

    Sicherlich ist es möglich, dass der Komprimierungsprozess gestört wird, wenn die Kamera nicht wegschreiben kann und der Puffer irgendwann voll läuft.

    Nutzt Du MxFFS Archivierung oder Buffered?

    Hat die NAS einen Vernünftigen Puffer / Arbeitsspeicher? Wie viele Platten? Wie viele Kameras speichern? Greifen weitere Applikationen  auf sie zu? Ist die Netzwerkstrecke bis zur NAS performant?

    Gruß Torben

    Disclaimer: Dies sind Einschätzungen übers Forum, ohne Analyse vor Ort. Ich würde nichts tauschen / neu kaufen, bevor Du nicht dem Mobotix-Support die Support-Datei rübergeschickt hast. Sie enthält noch wesentlich mehr Informationen 

     

    #21814

    MobotixFan
    Teilnehmer

    Hallo Torben,

    vielen Dank für Deine Einschätzung.

    Ich nutze entsprechend Deinen Empfehlungen MxFFS. 

    NAS und Switch sollten nicht das Problem sein – es speichern 4 weitere S15D (mit baugleichen SD-Karten) darauf ohne derartige Fehlermeldungen. Außerdem sollte ja gerade die Kombination aus SD-Karten- & NAS-Speicherung das Puffern auf der SD-Karte unterstützen, wenn das NAS gerade mal nicht erreichbar oder überlastet ist. Die Log-Daten auf dem Switch (Gigabit, managed) zeigen keine Störungen.

    Laut dem .eml-File (Support-Informationen) war die Pufferauslastung immer kleiner 30%. Es ist schon faszinierend, was eine Mobotix-Kamera so alles an Information speichert, das wäre fast mal ein Erklär-Video wert.

    Die Fehlermeldung „STORAGE check[1372] Transfer of image files delayed more than 120 seconds!“ kommt erst nach einiger Zeit, nachdem die Bilderzeugung neu gestartet wurde. Ich vermute, dass zunächst die Daten von der SD-Karte mit den Daten vom NAS abgeglichen werden. Dabei wird dann das „hole“ (also fehlende Bilder) detektiert. Ein paar Minuten später sind dann auch die Bilder übertragen: „STORAGE check[1372] Transfer of image files OK.“ …außer denen, die ganz am Anfang beim Starten der Bilderzeugung (oder kurz zuvor) verloren gingen.

    Zu Testzwecken habe ich das Speichern ausschließlich auf SD-Karte konfiguriert, leider mit ähnlichem Ergebnis (schwarzer Frame usw.)

    Die Support-Anfrage war ernüchternd, man könnte glatt meinen der Mobotix-Support will seine Kunden oder zumindest deren Probleme von sich fernhalten:


    „Ihr Anliegen wurde der Ticket Nummer XXXXXX zugeordnet. Bitte wenden Sie sich mit dieser Ticket Nummer an Ihren Händler. Dieser wird Ihnen in den meisten Fällen direkt helfen können. Ihr Händler wird sich, falls nötig, noch einmal mit Ihrer Ticket Nummer mit uns in Verbindung setzen, um Sie bestmöglich zu unterstützen.

    Für einen weitergehenden Support werden von Ihrem Händler zusätzliche Daten benötigt. Im anhängenden Dokument finden Sie hierzu eine Auflistung.

    Sollten Sie aktuell keinen Händler haben, finden Sie über die folgende Suche einen Partner in Ihrer Nähe:

    vvvvvv.mobotix.c0m/de/partner-finden

    Ihr Ticket wird aktuell nicht weiter bearbeitet. Bis Ihr Händler, sofern erforderlich, mit uns in Kontakt tritt, wird Ihr Ticket vorübergehend in eine Warteposition gesetzt.“


    Das klingt für mich nach einer automatisierten Antwort, um das Thema auf einen Händler abzuwälzen. Wozu macht sich der Kunde denn die Arbeit, d.h. beschreibt das Problem, speichert Video-Sequenzen, Screenshots und Support-Informationen ab? Damit man dann über einen Dritten kommuniziert? Sicher ein Händler kann bestimmt mehr als 90% der Anfragen direkt klären. Aber man könnte auch Fall-spezifisch reagieren. An der Fehlerbeschreibung und den zur Verfügung gestellten Daten erkennt man schnell die Ver­siert­heit des Kunden.

    Früher hat der Mobotix-Support zwar ein paar Tage gebraucht, mit der Antwort hat man dann konkret was anfangen können.

    Diese Lücke schließt jetzt camtelligence.de, vielen Dank für diesen Service, Torben!!!

    Grüße, ein MobotixFan

    PS: Torben, Du wirst nicht unter >>>vvvvvv.mobotix.c0m/de/partner-finden<<< aufgeführt. Das ist schade, schließlich bekommt man bei Dir den Support, den man bei einem hochpreisigen Produkt neben der Qualität auch erwartet.

    #21822

    Torben Vanselow
    Keymaster

    Hallo Mobotix-Fan,

    Bzgl. meiner ursprünglichen Frage; MxFFS oder Buffered Archive: Es gibt für die Mx6-Plattform und mittlerweile, nach Firmwareupdate, auch für die x4 / x5 er (P3) Plattform, die Funktion Buffered MxFFS/ Archive. Bei Nutzung dieser Methode, wäre eben genau der positive SD-Karten-Puffer nicht zum Tragen gekommen, da die SD-Karte nur bei Netzwerkausfall etc. verwendet wird. 

    Buffered MxFFS ist also entsprechend stärker auf performante Netzwerk/Storage-Strukturen angewiesen. Diese Methode nutzt Du aber nicht und somit ist dies als Ursache raus.


    Deine Versiertheit erkenne ich auf jeden Fall an der professionellen, elaboraten und sehr genauen Fehlerbeschreibung!

    Sehr interessanter Fehler. Vor allem hat mich das Fortbestehen des Fehlers, bei Speicherung auf (nur) SD-Karte einigermaßen überrascht.

    Mir ist diese Phänomen so noch nicht untergekommen und auch der Mobotix-Support ging prompt von in Richtung NAS liegenden Ursachen aus.

    Somit fällt das Forum als alleiniger Lösungsansatz durch Erfahrungsaustausch wohl aus.


    Zum Mobotix-Support

    Die Kollegen beim Mobotix-Support leisten, meiner Meinung nach, erstklassige Arbeit. 

    Eine gewisse Unzufriedenheit mit der Vorgehensweise hinsichtlich Endkunden, wird immer mal wieder zum Thema. Soweit ich das, auch als ehemaliger Mobotix-MA einschätzen kann, liegt dies aber auch zu einem nicht unerheblichen Teil, in einer unzureichenden Kommunikation der Händler und Partner begründet. 

    Denn diese haben sich beim Hersteller zur Leistung des 1. Level-Supports verpflichtet. Um Partner zu werden und diese Anforderung überhaupt erfüllen zu können, müssen Anwärter an Schulungen teilnehmen.

    Für mich ist es immer wieder ein Mysterium, in wie vielen Fällen diese Information gar nicht weitergegeben wird und die Erfüllung dieser Verpflichtung einfach ausgesetzt wird.

    Übrigens – ich war schon gewerblicher Kunde bei so einigen namenhaften Herstellern im Sicherheitsgewerbe. Die meisten wissen, dass es nicht machbar ist, der großen Masse an Endkunden, mit teilweise geringen oder komplett nicht vorhandenen Fachkenntnissen, direkten Support zu leisten.

    Bei zwei Herstellern bekamen wir die Support-Telefonnummer erst nach Absolvierung der Schulungen und auch unsere Telefonnummern wurden im System hinterlegt. Wir kamen also nur beim Support durch, wenn wir von einer registrierten Nummer anriefen.

    Ich verstehe Deinen Wunsch nach Einzelfallentscheidungen. In Konzernen mit Prozeduren und Richtlinien für alles was man sich vorstellen kann, bleibt dies aber gewöhnlich aus.


     

    In der Praxis braucht Dein Händler nur ein Ticket zu eröffnen und schon ist alles im grünen Bereich.

    Ich möchte jetzt auch nicht fragen, wo Du die Kameras erworben hast – wir möchten hier niemanden in die Pfanne hauen.

    Wärst Du jetzt CamTelligence-Kunde, wären wir schon längst zwei Schritte weiter 🙂

    Gerne könntest Du die Kaffeemaschine am rechten Rand einmal komplett bis zum Anschlag auffüllen. Der Geruch von Kaffee würde mir neue Energie geben, Deinen Fall, gemeinsam mit dem Mobotix-Support, mal gründlich zu recherchieren 🙂

    Hierzu benötigte ich noch die Support-Informationen und die bisherige Ticketnummer an i n f o (at) c a m t e l l i g e n c e . d e

Ansicht von 4 Beiträgen - 1 bis 4 (von insgesamt 4)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.